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1 Introduction

The CAN interface PCAN-USB XL ensures an uncomplicated connection to CAN XL,
CAN FD, and CAN CC buses via the USB port of a computer. Galvanic isolation of up
to 500 Volts decouples the PC from the CAN bus. With its compact plastic casing, it is
ideal for mobile applications.

The PCAN-USB XL is delivered ready to use with Windows and Linux drivers, the
PCAN-View monitoring software, and the PCAN-Basic API for developing applications
with CAN connection. PCAN-Basic 5 and PCAN-View 6 support the new standard CAN
XL.

CAN XL

CAN XL (Extended Data-Field Length) was designed to improve the cooperation of
CAN and TCP/IP networks and to enable transmitting larger data streams for use
cases such as ECU flashing and software updates. For this, the new standard
provides bit rates of up to 20 Mbit/s and data transmission with up to 2048 bytes per
message.

Device drivers and application information for Linux:
www.peak-system.com/quick/DL-Driver-E

‘ e This manual describes the use of the CAN interface with Windows.
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1.1

Properties at a Glance

B CAN interface for High-speed USB 2.0 (compatible to USB 3.0)
High-speed CAN connection (ISO 11898-2:2024)

Complies with CAN specifications CAN CC (classic CAN 2.0), CAN FD, and
CAN XL (I1SO 11898-1:2024)

CAN bit rates from 20 kbit/s up to 1 Mbit/s

CAN FD data bit rates up to 8 Mbit/s

CAN XL data bit rates up to 8 Mbit/s, CAN FD compatible transmission mode
CAN XL data bit rates up to 20 Mbit/s by using the transceiver mode switch
CAN bus connection via D-Sub, 9-pin (in accordance with CiA® 106)

B Time stamp resolution 1 us

FPGA implementation of the CAN XL core by PEAK-System; validated with the

CAN XL Evaluation Board by C&S (www.cs-group.de)

CAN SIC XL transceiver TI TCAN6062V

Galvanic isolation between CAN and USB up to 500 V

CAN termination can be activated through solder jumpers

Voltage supply via USB

Extended operating temperature range from -40 to +85 °C (-40 to +185 °F)

= PCAN-USB XL
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1.2 Scope of Supply
B PCAN-USB XL in plastic casing

Downloads
B Device drivers for Windows 11 (x64/ARM64), 10 (x64), and Linux
B CAN monitor PCAN-View for Windows

B Programming interface PCAN-Basic for developing applications with CAN CC, CAN
FD, and CAN XL connection

B Programming interfaces for standardized protocols from the automotive sector
B Manual in PDF format

1.3 System Requirements

Computer with:
B Operating system Windows 11 (x64/ARM64), 10 (x64), or Linux
A free USB port (USB 2.0, USB 3.0)

= PCAN-USB XL

User Manual 1.0.0 = © 2026 PEAK-System Technik GmbH




2  Settings

The following describes the setting for the internal termination. If you do not need
this setting, skip this chapter.

2.1 Internal Termination

The internal termination can be activated by solder jumpers on the circuit board to
terminate one end of the CAN bus. At delivery the termination is not activated.

:'1 Tip: We recommend to do termination at the CAN cabling, for example
= with the terminating resistors PCAN-Term (IPEK-003002) or
PCAN-MiniTerm (IPEK-003002-Mini). Thus, CAN nodes can be flexibly
connected to the bus.

2.1.1 Activate Internal Termination

g Risk of short circuit! Soldering on the CAN interface may only be
performed by qualified electrical engineering personnel.

Py Attention! Electrostatic discharge (ESD) can damage or destroy
= components on the card. Take precautions to avoid ESD.

1. Open the CAN interface casing. Push the latches on both sides cautiously with a
slotted screwdriver.

2. Remove the circuit board.

2 Settings = PCAN-USB XL
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3. Set the corresponding solder bridges on the circuit board.

Circuit board of hardware version 4

Termination High-speed CAN bus 120 Q
Without (default) Activated

I . [ ][]

4. For assembly, place the circuit board on the upper half of the housing. The strain
relief and the LED must be in the corresponding recesses.

5. Press the lower half of the housing onto the upper half of the housing until the
latches engage.
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3 Installation

This chapter covers the software setup for the PCAN-USB XL interface under
Windows and the connection of the CAN interface to the computer.

Install the driver before you connect the CAN Interface

3.1 Install Device Driver Setup

1. Download the device driver setup from our website:
www.peak-system.com/quick/DL-Driver-E

2. Unpack the file PEAK-System Driver-Setup.zip
3. Double-click the file PeakOemDrv.exe

The driver setup starts.
4. Follow the program instructions.

3.2 Connecting the CAN Interface

Attention! Do not use a USB extension cable to connect the
CAN interface to the computer. Extension cables do not comply with the
USB specification.

1. Connect the CAN interface to a USB port of the computer or of a connected USB
hub. The computer can remain powered on.
Windows detects the new hardware and completes the driver installation.

2. Check the LED on the CAN interface. If the LED is blue the driver was initialized
successfully.
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4  Connecting the CAN Bus

4.1 Connection over D-Sub Connector

After the CAN interface is connected, a CAN bus can be connected to the
D-Sub connector. The pin assignment for CAN corresponds to the specification
CiA® 106:

Pin Assignment D-Sub plug

Not connected

CAN_Low

CAN_GND 1 2 3 4 5
Not connected

Not connected

CAN_GND

CAN_High 6 7 8 9

Not connected

O 0 N o A~ W N =

Not connected
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4.2 Cabling

4.2.1 Termination

The High-speed CAN bus (ISO 11898-2) must be terminated with 120 Q on both ends.
The termination prevents interfering signal reflections and ensures the proper
operation of the transceivers of the connected CAN nodes (CAN interfaces,

control devices).

The PCAN-USB XL has an optional internal termination with 120 Q. For more

information see chapter 2.1 Internal Termination.

4.2.2 Example of a Connection

IPEK-003002/-mini

b IPEK-003001 g
PC PCAN m [ EEEEE ( m ECU
— O
Interface : J ]
1200 1200
= b IPEK-003000 |
PC el [------_1 ;
Interface ) a) L ‘
1200 1200

IPEK-003002/-mini

This example shows a connection between the PCAN Interface and a control unit
(ECU). The upper example shows a connection with a cable which is terminated with
120 Q at both ends. At the lower example the connection is made with termination

adapters.
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4.2.3 Maximum Bus Length
The maximum bus length depends on the nominal bit rate:

Nominal bit rate Buslength

1 Mbit/s 40 m
500 kbit/s 110 m
250 kbit/s 240 m
125 kbit/s 500 m
50 kbit/s 1.3 km

The listed values have been calculated on the basis of an idealized system and can
differ from reality.

apply for CAN FD and CAN XL as for CAN. The dependency is based on

o Note: Despite the higher data bit rate, the same maximum bus lengths
the nominal bit rate during arbitration.
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5 Operation

5.1 Status LED

The LED can be in the following states:

Status Meaning

Blue on There's a connection to a driver of the operating system.

Blue slow blinking A software application is connected to the interface.

Blue quick blinking Data is transmitted via the connected CAN bus.

Red blinking An error is occurring during the transmission of CAN data.

Orange quick blinking Identification of an interface when multiple interfaces are plugged.

5.2 Unplugging the USB Connection

The PCAN-USB XL interface can be disconnected from the computer without further
actions. In Windows, the interface is not listed under "Safely Remove Hardware".

5.3 Distinguishing several PCAN-USB XL Interfaces

You can operate several PCAN-USB XL interfaces on a single computer at the same
time. The supplied program PEAK-Settings allows the assignment of device IDs in
order to distinguish the CAN interfaces in a software environment.

PEAK-Settings is part of the device driver setup and can be started by entering PEAK-
Settings in the Windows search bar. More information, see Distinguishing between
multiple CAN interfaces on page 24
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6  First Steps with PCAN-Explorer 7

For owners of a PCAN-Explorer 7 license, this chapter covers the first steps with the
program.

B Setting Up a CAN Connection
B Creating a Send Message
B Tracing CAN Messages

The procedures are described in the following sections.

You can obtain detailed program help in the PCAN-Explorer by pressing F1.

6.1 Setting Up a CAN Connection

PCAN-Explorer does not directly access a CAN interface to establish a CAN
connection. Instead, a so-called PCAN Net, basically a virtual CAN bus in the
computer, is used. The PCAN Net defines the bit rates and the CAN interface to the
physical CAN bus.

Creating a PCAN Net

PCAN Nets are managed with the separate Windows program PCAN Nets
Configuration independently of the PCAN-Explorer. The process for creating a PCAN
Net is usually carried out once. Afterwards, the PCAN Net can be used by the PCAN-
Explorer in different situations.

1. Make sure that the CAN interface PCAN-USB XL is connected to the computer and
that its LED lights up blue.

2. Start the PCAN Nets Configuration program via the Windows Start menu and
expand the USB category in the tree view.

The PCAN-USB XL CAN interface appears in the list.

3. Right-click on the PCAN-USB XL entry to open the context menu and select New
Net.

The Net Properties dialog box appears.
4. Enter a name for the Net in the corresponding field.

6 First Steps with PCAN-Explorer 7 = PCAN-USB XL
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5. On the CAN Setup tab, select the CAN Mode to be used.

Make sure that you configure the PCAN Net according to the
parameters used on the CAN bus, also in the following step.

6. Assign the Clock Frequency as the starting point and the bit rates to the new PCAN
Net.

7. Confirm the entries with OK.

A new entry under PCAN-USB XL appears in the main window of PCAN Nets
Configuration.

8. Click on Save to save the changes to the Net configuration on your computer.

» PCAN Nets Configuration

DESKTOP-TIR3RGE
Object Info
= ¥ use ¥5.0.0.173
% Internal
Device 1D 108h, GUID Tabed08e-bb56-4972-bI5f-dcd5900db251
160 MHz, 500 kbit/s (nominal), 2 Mbit/s (FD data), 4 Mbit/s (XL data)

The created PCAN Net is now available to the PCAN-Explorer for a connection.

6 First Steps with PCAN-Explorer 7 = PCAN-USB XL
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Establishing a Connection in the PCAN-Explorer
1. Start the PCAN-Explorer.
2. Create a new Project via File > New > New Project.
Project 'Projectl' appears in the Project Manager window on the right.

3. Give the project a name. To do this, right-click on the Project entry and select
Rename.

4. In the Connections window at the bottom, select Add.

In the dialog box that appears, the previously created network is displayed on the
USB tab.

5. Make sure that the network is selected - no further information is required - and
confirm with OK.

The Receive area displays the incoming CAN messages of the connected CAN bus.

Tools Window  Help

sl v i) r:|

|V % columns: | can 9~ A0 % =h -

Fier | 5 None
O Bus  Type CAN-ID (he) ~ Length Symbol Dats Timing Errors Cycle Time Count || [ Project First-XL-Project’
1 0 25 03 2707 4F 5668 EE DCCB A4 07 94 2., 1132 3670
1 2048 02 BE 83 31 FC5D87 8DD5 4C59 89 05 BE 1F 05 1357
1 0 4 Am2c3075 43 s1a7s
1 w 0 480502 C1F5 82 1013665991005 73 5 .. 1951 2036
| mEE s o 48 59 C2 28 49,43 27 EF 2087 27 £6 80 CE 63.. 1951 20see
2 1OME oo e A3 EE 28 9E BE 91 1ADE 3007 01w
2 1 oosazs2 x DABS EF 25 83,0824 4983 75 07 6C 11 82 AD. 3007 o104
4 (] wasne s 4637 0588.CE 189F B 91 a1
o

O Bus  Type CAN-D(he)  Length  Symbol Data Cycle Time Count Trigger Creator

) 0Og00z
= 3

X @ Add.. o€ Reset
Bus Nome Net Connection it Rote Stetus Overruns mifulls Options BusLoad
)

£{8 1 & Connection] ' XL-Net 500k-2M-4M@pcan_usb Nominal 500 kbit/s, FD Data 2 Mbit/s, XL Data 4 Mbit/s oK. (]

6. Save the current settings to any location using File > Save Project As. Later, you
can quickly regain access to the CAN bus by opening the Project without having to
repeat the settings in detail.
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6.2 Creating a Send Message

CAN messages with static data are assembled in the Transmit section of the PCAN-
Explorer. When doing so, several entries with the same CAN ID or PID can be
provided, each with different data bytes.

This procedure requires at least one Connection using CAN XL.

Creating a New CAN XL Transmit Message

1. If the Receive / Transmit window is not visible, select the menu command View >
Receive/Transmit.

2. Above the Receive area, switch the Columns view to CAN XL in order to be able to
see all the key data of the CAN XL messages in the lists.

3. Select the menu command Send > New Message.
The Edit Message dialog box appears.
4. Indicate a Type for the new CAN XL message:
B CAN XL: freely configurable CAN XL message with selectable Service Data Type
(SDT)

B CAN XL (... Tunneling): Transmission of a CAN CC or CAN FD message embedded
in a CAN XL message (SDTs 03h, 06h, 07h)

5. Specify the parameters and data for the CAN XL message. When using the
tunneling types, you can specify the basic parameters of the embedded CAN CC or
CAN FD message as usual.

6. Using the Cycle Time field, specify if the message is to be transmitted periodically
(value greater than 0) or only manually (value 0).

7. Confirm the settings with OK.

The completed transmit message appears in the Transmit area and is transmitted
with the specified data periodically according to the set cycle time.

8. To transmit manually, select this or another transmit message from the list and
press Space.

The CAN message is transmitted once, when having a periodically transmitted
CAN message once in addition. This is also indicated in the Count column.

6 First Steps with PCAN-Explorer 7 = PCAN-USB XL
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6.3 Tracing CAN Messages

You can easily record the whole traffic of incoming and outgoing CAN messages to a
trace file. Starting with trace format version 3.0, PCAN-Explorer 7 can also handle
CAN XL messages in trace files.

Starting a Trace Recording

1. Make sure that your current Project in PCAN-Explorer is saved. You can use File >
Save Project As.

By default, PCAN-Explorer uses the Project’s directory for creating a temporary
subdirectory for trace files.

2. Select Trace > Start New Tracer.
A new window appears, showing all occurring messages being written to the trace
file.

3. Stop the recording with Trace > Stop.
The trace file now exists in the temporary location that is indicated on the tab
label. When hovering with the mouse over this label, you can see the full path in
the info bar on the bottom of the PCAN-Explorer window.

4. Use File > Save As to move the trace file from its temporary location to a path of
your choice.

You can use the PCAN-Explorer to play back trace files on a connected CAN bus.
Another possibility is to extract Signals from the CAN messages of a trace file by
using symbol files.

6 First Steps with PCAN-Explorer 7 = PCAN-USB XL
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7 APl PCAN-Basic

rights. Read the license agreement for end users at:
https://www.peak-system.com/quick/eula

‘ 0 The intended use of PCAN-Basic requires compliance with the license

The programming interface (API) PCAN-Basic provides basic functions for the
connection of own programs to CAN CC, CAN FD, and CAN XL buses using Interfaces
from PEAK-System. PCAN-Basic is the interface between the program and the device
driver. In Windows operating systems, these are DLL files (Dynamic Link Library) and
in Linux operating systems an SO (Dynamic Shared Object). PCAN-Basic is designed
to be cross-operating system compatible. Software projects can be ported between
supported systems with little effort.

With the installation of the device driver package under Windows the DLL files of the
APl PCAN-Basic are placed in the system folder. Examples for all common
programming languages as well as libraries and help files are available as a
download package at: www.peak-system.com/quick/DL-Develop-E

7 API PCAN-Basic = PCAN-USB XL
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For Linux, a download of the API is available under this link. For a use of PCAN-Basic
another driver package with a chardev driver is needed, because an access under
SocketCAN is not possible. The "Driver Package for Proprietary Purposes", the user
manual, and further information about the implementation can be found at
https://linux.peak-system.com

7.1 Features of PCAN-Basic

B API for developing applications with CAN CC, CAN FD, and CAN XL connections

B Support for CAN specifications CAN CC (classic CAN 2.0), CAN FD, and CAN XL (ISO
11898-1 2024)

B Application development for the platforms Windows 11 (x64/ARM64), 10 (x86/x64),
and Linux

B Multiple PEAK-System applications and your own can be operated on a physical
channel at the same time

Use of up to 16 channels for each hardware type

Simple switching between channels of a PEAK CAN interface

Access to the CAN channels of a PCAN-Gateway via the PCAN-LAN hardware type
Driver-internal buffering of up to 32,768 CAN messages per CAN channel

Precision of time stamps on received messages up to 1 us (depending on the
PEAK CAN interface used)

B Supports PEAK-System’s trace formats
B Version 1.1 for CAN CC recordings

B Version 2.0 for CAN FD recordings
B Version 3.0 for CAN XL recordings
B Access to specific hardware parameters, such as listen-only mode

Notification of the application through Windows® events when a message is
received

Support of CAN error frames

Confirmation of physical transmission by CAN echo frames
Extended system for debugging operations

Multilingual debugging output

Output language depends on operating system

7 API PCAN-Basic * PCAN-USB XL
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B Debugging information can be defined individually
B Thread-safe API

7.2 Principle Description of the API

The sequence of accessing the CAN interface is divided into three phases:

Initialization

A CAN channel must be initialized before using it. This is done by the simple call of
the function CAN Initialize for CANCC,CAN InitializeFD for CAN FD, and
CAN InitializeXL for CAN XL. Up to 16 CAN channels can be opened at the
same time. After a successful initialization the CAN channel is ready. No further
configuration steps are required.

Interaction

For receiving and transmitting messages the functions CAN Read and CAN Write,
CAN ReadFDand CAN WriteFD, as well as CAN ReadXL and CAN WriteXL
are available depending on the initialization mode. Additional settings can be done,
such as setting up message filters to confine to specific CAN IDs or setting the

CAN controller to Listen-only mode.

With the corresponding parameter activated, events are used to automatically notify
an application (client) when CAN messages are received. This offers the following
advantages:

B The application no longer needs to check for received messages periodically (no
polling).
B The response time at reception is reduced.

Completion

To end the communication the function CAN Uninitialize is called in order to
release the reserved resources for the CAN channel, among others. In addition the
CAN channel is marked as "Free" and is available to other applications.

7 API PCAN-Basic * PCAN-USB XL
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8 Hardware Management with
PEAK-Settings

PEAK-Settings is a software that can be used to display, manage, and configure all
available devices, installed drivers, and APIs of PEAK-System.
8.1 Installation

PEAK-Settings is installed together with the device driver setup of PEAK-System.

8.2 Working with PEAK-Settings

After installation, the software can be started. To do this, enter PEAK-Settings in the
search field.

When you run PEAK-Settings, the start page is displayed. From here you can navigate
to the individual categories.

PEAK Settings

RP1210C
ings for RP1210C

8 Hardware Management with PEAK-Settings * PCAN-USB XL
User Manual 1.0.0 = © 2026 PEAK-System Technik GmbH




Distinguishing between multiple CAN interfaces

All connected CAN interfaces are listed in the CAN hardware area. Information about
the device ID, the GUID, the firmware version and the number of channels can be
called up here.

You can operate several interfaces of the same type on one computer. The device ID
and GUID make it possible to identify the hardware in a software environment. The
GUID is an unchangeable, unique string. The device ID, on the other hand, can be
configured with PEAK settings as follows.

1. Click on CAN Hardware to display the connected hardware.

2. Enter a hexadecimal number ending in “h” as the new hardware ID.

3. Confirm the entry with Set.
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9 Technical Data

Connectors

Computer
CAN
UsB

CAN
Protocols

Physical transmission

Bit rates

Controller
Transceiver
Galvanic isolation

Internal Termination

Time stamp resolution

Power supply
Rated voltage

Current consumption

Measures

Size

Connection cable length

Weight

9 Technical Data = PCAN-USB XL

USB plug type A
D-Sub (m), 9 pins, pin assignment according to CiA® 106
High-speed USB 2.0, compatible with USB 3.0

CAN CC, CAN FD, and CAN XL according to ISO 11898-1:2024;
non-ISO CAN FD

1SO 11898-2:2024 (High-speed CAN)

Nominal: 20 kbit/s to 1 Mbit/s
CAN FD data bit rates: max. 8 Mbit/s

CAN XL data bit rates

(CAN FD compatible): max. 8 Mbit/s

CAN XL data bit rates

(with transceiver mode switch): max. 20 Mbit/s
FPGA implementation

CAN SIC XL transceiver TI TCAN6062V

500V

120 Ohm between CAN-High and CAN-Low via solder bridges, disabled
at delivery

1ps

+5V DC (via USB connection)
max. 250 mA

75x43 x22mm
approx. 0.75 m
9g
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Environment
Operating temperature

Temperature for storage
and transport

Relative humidity

Ingress protection
(IEC 60529)

Conformity

RoHS

EMC

9 Technical Data = PCAN-USB XL

-40 to +85 °C (-40 to 185 °F)
-40 to +100 °C (=40 to 212 °F)

15 to 90 %, not condensing
1P20

EU Directive 2011/65/EU (RoHS 2) +2015/863/EU
DIN EN IEC 63000:2019-05

EU Directive 2014/30/EU
DIN EN 55032:2022-08
DIN EN 55035:2018-04
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Appendix A Dimension Drawings
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Appendix B CE Certificate

EU Declaration of Conformity PEAK

System

This declaration applies to the following product:

Product name: PCAN-USB XL
Item number(s): IPEH-005022
Manufacturer: PEAK-System Technik GmbH

Leydheckerstrale 10
64293 Darmstadt
Germany

c We declare under our sole responsibility that the mentioned product is in
conformity with the following directives and the affiliated harmonized standards:

EU Directive 2011/65/EU (RoHS 2) + 2015/863/EU (amended list of restricted substances)
DIN EN IEC 63000:2019-05

Technical documentation for the assessment of electrical and electronic products with respect
to the restriction of hazardous substances (IEC 63000:2016);

German version of EN IEC 63000:2018

EU Directive 2014/30/EU (Electromagnetic Compatibility)

DIN EN 55032:2022-08

Electromagnetic compatibility of multimedia equipment - Emission requirements
(CISPR 32:2015);

German version of EN 55032:2015 + AC:2016 + A11:2020 + A1:2020

DIN EN 55035:2018-04

Electromagnetic compatibility of multimedia equipment - Immunity requirements
(CISPR 35:2016, modified);

German version of EN 55035:2017

Darmstadt, 28 April 2025

b %%f

Andreas Staat, Engineering Manager HW
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Appendix C  Disposal

The PCAN-USB XL must not be disposed of in household waste. Dispose of the
product properly in accordance with local regulations.
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